StopMotionAnimation.com

taking one frame at a time since 1999

Hi. Anyone running Dragonframe on Mac OS Catalina? If so, what camera do you recomend? After a decade of shooting all I do using only the camera display, no computer attached, i finally decided it was time to join the 21st century. I just bought a  macbook, got Dragonframe yesterday, and then ... It turns out my old Canon 5D Mk II is no longer supported by Catalina. wtf

Views: 42

Reply to This

Replies to This Discussion

Hi Gustavo.

My 2019 Macbook Pro is running Catalina (10.15.7). I am using Dragonframe 4 and have been able to connect with my Canon 5D Mk II, capture frames and export video.

What version of Catalina are you running? 

I wasn't even aware of this issue but a quick search shows others have struggled with this too. Appears some users have had luck connecting after they upgraded beyond Catalina 10.15.2. Can't speak to that solution, but it might be worth looking into.

...ben

Did you try writing to Dragonframe Support? Dyami usually gets back to me fairly quickly.

support@dragonframe.com

Here is their page about your camera.

https://www.dragonframe.com/camera-setup/canon_eos_5d_mark_ii/

I have used my Canon 7d on my 2013 iMac running Catalina, but not since the latest upgrade to OS 10.15.7 . (Mostly I use a much older 2008 Mac in the studio for capture.) Dragonframe is v 3.7.4.  I just connected the camera and took 2 frames, it seems to still be working.

Hi Ben. I am also running Catalina (10.15.7). Great news to know you are able to access Dragoframe 4 using your 5D Mk II. This means I don't have to write the camera off just yet! O.K. I'll dig in further. I'll get there.

ben mollica said:

Hi Gustavo.

My 2019 Macbook Pro is running Catalina (10.15.7). I am using Dragonframe 4 and have been able to connect with my Canon 5D Mk II, capture frames and export video.

What version of Catalina are you running? 

I wasn't even aware of this issue but a quick search shows others have struggled with this too. Appears some users have had luck connecting after they upgraded beyond Catalina 10.15.2. Can't speak to that solution, but it might be worth looking into.

...ben

Hi Nick, thanks for this. It definitely helps me get the right diagnostic on which part of the set up is at fault.

StopmoNick said:

I have used my Canon 7d on my 2013 iMac running Catalina, but not since the latest upgrade to OS 10.15.7 . (Mostly I use a much older 2008 Mac in the studio for capture.) Dragonframe is v 3.7.4.  I just connected the camera and took 2 frames, it seems to still be working.

Hi Anthony, thanks for the advise, I'll get in touch with the folks at Dragonframe. They'll no doubt have more of a clue than I.

Did you try writing to Dragonframe Support? Dyami usually gets back to me fairly quickly.

support@dragonframe.com

Here is their page about your camera.

https://www.dragonframe.com/camera-setup/canon_eos_5d_mark_ii/

Ben, Anthony, and Nick. Just a big thanx for your generose advise. I'll be out of this issue  shortly. 

O.K.!!!! I cracked it. !!!! After trying out obscure software fixes to no avail I wiggled the bloody USB cable in desperation prior to putting the computer in the bin. The camera was recognised by Catalina and Dragonframe picked up.!!! All along it was nothing but a dodgy USB cable connection. Oh my. What a total moron. Case closed.

Those darn cables. I've had issues with Canon AC Power cables in the past. I didn't even think that a cable could be the issue with your setup. Sounds like you figured it out just in time!

gustavo arteaga said:

O.K.!!!! I cracked it. !!!! After trying out obscure software fixes to no avail I wiggled the bloody USB cable in desperation prior to putting the computer in the bin. The camera was recognised by Catalina and Dragonframe picked up.!!! All along it was nothing but a dodgy USB cable connection. Oh my. What a total moron. Case closed.

We all feel your frustration!

I upgraded to a Tether cable, which costs a lot, but is supposed to be best quality. The connector is still a bit wobbly in the camera, though.

https://www.amazon.co.uk/dp/B00827MK3S?psc=1&ref=ppx_pop_dt_b_a...

Hi Anthony. Yea, that Mac was proper heading for the bin or wot!!. Anyway. All is well that ends well. I am glad it was just a cable issue. As always, the devil is in the details.


Anthony Scott said:

Those darn cables. I've had issues with Canon AC Power cables in the past. I didn't even think that a cable could be the issue with your setup. Sounds like you figured it out just in time!

gustavo arteaga said:

O.K.!!!! I cracked it. !!!! After trying out obscure software fixes to no avail I wiggled the bloody USB cable in desperation prior to putting the computer in the bin. The camera was recognised by Catalina and Dragonframe picked up.!!! All along it was nothing but a dodgy USB cable connection. Oh my. What a total moron. Case closed.

Hi Simon, O.K. I didn't know about them Tether cables. Thanks for the link.

We all feel your frustration!

I upgraded to a Tether cable, which costs a lot, but is supposed to be best quality. The connector is still a bit wobbly in the camera, though.

https://www.amazon.co.uk/dp/B00827MK3S?psc=1&ref=ppx_pop_dt_b_a...

Reply to Discussion

RSS

Website News & Tips

STOPMO JAM 3
This time, the theme is HALLOWEEN. All entries must be submitted by September 18, 2021. More info here.

NEW MEMBERS
If you are new to the site, please feel free to introduce yourself on 
this Message Board thread.

MY PAGE
Y
ou can now customize your personal page. Go to My Page/Customize My Page.

PRIVACY
To control who sees your posts and Profile Page, go to Settings/Privacy.

MESSAGE BOARD & BLOG POSTS
If you have a question for the community, it is best to post your question on the Message Board instead of a Blog. Blogs are best for featuring your stop motion projects.

VIDEO
When posting a video, if possible, use the Embed Code instead of the URL. Your video will be a larger, more viewable size.

MESSAGE BOARD CATEGORIES

If you have a question or are looking for answers, you'll find a wealth of information here on the Message Board.

BEGINNERS a good place to start
ANIMATOR TALK experienced animators
YOUR STOPMO FILM PROJECT what r u working on?
STORY script, storyboarding and storyreel
ANIMATION TOOLS
 what's a surface gage?
STOP MOTION & COMPUTERS Dragonframe and VFX
CAMERA & STAGE camera, lighting and moco rigs
SOUND lip-sync, sound effects and music 
ARMATURES ball & socket and wire 
MACHINE SHOP metalwork tool & talk 
SCULPTING sculpture information and advice 
HAIR & COSTUME materials and technique 
CASTING
 foam, silicone and resin 
CLAY clay puppet construction 
GENERAL PUPPET MAKING 
other puppet fab issues
STOP MOTION SETS set design and construction
MODEL DEPARTMENT
 miniature prop discussion

and even more...
MATTE PAINTINGS
GENERAL SPECIAL EFFECTS 
STOP MOTION FILM DISCUSSION 
FAVORITE STOP MOTION CHARACTERS
PRO ANIMATOR DISCUSSION
FILM FESTIVALS AND EVENTS 
ANIMATION SCHOOLS 
STOP MOTION BOOKS 
STOP MOTION ON VIDEO 
WORK OPPORTUNITIES

FOR SALE 
CHAT BOARD 

WEBSITE NEWS AND FEEDBACK

SMA.com on YouTube

© 2021   Created by Anthony Scott.   Powered by

Badges  |  Report an Issue  |  Terms of Service

.xg_widget_forum_index_index .xg_column.xg_span-7.xg_last {display:none;} .xg_widget_forum_topic_listForCategory .xg_column.xg_span-7.xg_last {display:none;} .xg_widget_forum_topic_show .xg_column.xg_span-7.xg_last {display:none;}